NIC handle
A NIC handle (network information centre handle) is a unique alphanumeric character sequence that represents an entry in the databases maintained by network information centres. When a new domain name is registered with a domain name registrar, a NIC handle is assigned by the registrar to the particular set of information associated with that domain name (such as who registered it and a contact e-mail address). Once a domain name has been registered, its NIC handle can be used to search for that record in the database.[1][2][3]: 19
The NIC handle was developed in 1982 by Ken Harrenstien and Vic White working at the early Network Information Center at SRI International.[4]
Modern use
The NIC handle system is no longer commonly used by domain name registries. It was previously possible to query WHOIS by NIC handle, and see all the domains registered by that NIC handle,[5]: 36 but this service was discontinued (presumably due to spam).
NIC handles are still used extensively in the RIPE Database to identify people and business roles.
References
- ↑ Hunt, Craig (1993). TCP/IP Network Administration. O'Reilly. p. 352–353. ISBN 093717582X. https://archive.org/details/tcpipnetworkadmi00hunt/page/n375/.
- ↑ Hunt, Craig; Robert Bruce Thompson (1998). Windows NT TCP/IP Network Administration. O'Reilly. p. 87. ISBN 1565923774. https://www.google.com/books/edition/Windows_NT_TCP_IP_Network_Administration/6hlNFc7drzEC?hl=en&gbpv=1&dq=%22NIC+handle%22&pg=PA87&printsec=frontcover.
- ↑ Baker, Steven (September 1993). "The Evolving Internet Backbone". UNIX Review (UBM LLC) 11 (9): 15–21. https://link.gale.com/apps/doc/A14208337/GPS?u=fcla_main&sid=bookmark-GPS&xid=8ce5d04b.
- ↑ "RFC-812: NICNAME/WHOIS". Network Information Center, SRI International. https://datatracker.ietf.org/doc/html/rfc0812. Retrieved 2016-06-07.
- ↑ Goldstein, Mark (May–June 2003). "Who Was, Whois, and Who Will Be: Domain Name Ownership Research Tools". Online (Information Today) 27 (3): 34–40. https://link.gale.com/apps/doc/A101531870/GPS?u=fcla_main&sid=bookmark-GPS&xid=e3c5f68d.
External links
- "RFC 954: NICNAME/WHOIS". Network Information Center, SRI International. https://www.ietf.org/rfc/rfc954.txt. Retrieved 2016-06-07.
- "RFC 1032: DOMAIN ADMINISTRATORS GUIDE". Network Information Center, SRI International. https://www.ietf.org/rfc/rfc1032.txt. Retrieved 2016-06-07.
